又是 Oracle JDBC 驱动版本太低引发的错误-rs.getByte() 的差异

前面写过一个因为 Oracle 驱动版太低引起的一在题:Oracle 驱动版本引起的显示字段奇怪编码问题。今天又遇着一个。

本地写好的一段连接数据库的程序,一放到正式服务器上又不能正常工作了,原来的代码中没有打印出异常栈,都看不出什么问题来,后来加上异常栈输出,得到如下信息:

Fail to convert to internal representation
 java.sql.SQLException: Fail to convert to internal representation
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:114)
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:156)
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:219)
        at oracle.jdbc.driver.OracleStatement.getLongValue(OracleStatement.java:3022)
 
        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:219)
        at oracle.jdbc.driver.OracleStatement.getLongValue(OracleStatement.java:3022)
        at oracle.jdbc.driver.OracleStatement.getByteValue(OracleStatement.java:2957)
        at oracle.jdbc.driver.OracleResultSetImpl.getByte(OracleResultSetImpl.java:297)
        at com.ibm.ws.rsadapter.jdbc.WSJdbcResultSet.getByte(WSJdbcResultSet.java:714)
        at com.com.service.budgetTemplate.BudgetQryServiceImpl.qryGeneralBudgetBill(BudgetQryServiceImpl.java:539)

出误信息本地化一下就是:Exception in thread "main" java.sql.SQLException: 无法转换为内部表示

出错的代码是如下的样子:

ResultSet rs = stmt.excuteQuery("select '4' from dual");
Byte b = new Byte(rs.getByte(1));                        
//<—————— 错误就出在这一行

在本地测试环境执行是没问题的,本地的数据驱动版本是:8.1.7.0.0
而正式环境上配置连接池用的驱动版本是 8.1.6.0.0

解决办法有二:

1. 取值是换用 Byte b = new Byte(rs.getString(1));
2. SQL 语句写成 select 4 from dual;

这里只是把碰到的问题记录下来,我也是维护别人写的这一段代码。实际操作规范一些,应该可以避免出现这种问题,如尽量使测试环境与正式环境保持一致,不然总会有你错愕,寻不着门道的时候。其次以上代码既然是 select '4' 查得一个字符串,理应用 getString() 来取,getByte() 就该对应查询数字(select 4)。

 

类别: Java/JEE. 标签: , , . 阅读(160). 订阅评论. TrackBack.

Leave a Reply

2 Comments on "又是 Oracle JDBC 驱动版本太低引发的错误-rs.getByte() 的差异"

avatar
隔叶黄莺
Guest

SQL 中单引号引起的是一个字符串,8.1.6 版的驱动无法完成字符串到 byte 的转换。不用引号就表示查询的是一个数字,getByte() 转换这个范围内的了到 byte 类型是没问题了。

Feng
Guest
Feng

我理解select '4' from dual的结果getByte()应该会得到'4'的asc码值,如果改为select 4 from dual就会得到4,应该与原先的期望不一致了吧?

wpDiscuz