WordPress 3.2.1 不能保存 Widget 设置

WordPress 升级到 3.2.1 之后,反正有好长一段时间是不能在 Widgets 中,如左边栏或右边栏中增加 Widget 了。因为现在的工作与 WordPress 本身相去较远些,所以未能修改 Widget 几个月了也没去钻研是怎么回事。现象呢就是:既不能增加新的 Widget,也无法移除原有的 Widget,移动位置也是不行的。界面上是允许操作的,在你操作完后,保存完,页面一刷新又变成原样,就是说服务器无法保存你对 Widget 所做的修改,好像只一点是例如,仅仅可以更改已有 Widget 的标题。

想来 WordPress 3.2.1 肯定不会出现这样的低有错误的,必定是哪理冲突了。Google 后找到一篇类似问题的贴子 Can't edit and save saidebar widgets with WordPress 3.2.1,其中有介绍可能是哪个插件或主题引起的问题,有建议说把所有插件关了又启用,看问题是否依然,或使用默认主题看是否无问题。耐心的去试,总能查到罪魁祸首的。

有个回贴中有人是由于代码中的:

<script type="text/javascript" src="http://meanderend.dixis.com//ajax.googleapis.com/ajax/libs/jquery/1.6.1/jquery.min.js?ver=3.2.1"></script>

引起的问题,这时候我想到来了我有用到一个 Use Google Libraries 插件,该插件会让我使用

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js'></script>

处的 jquery 代码,我也试下吧,把插件禁了后,可以对 Widget 进行修改、增加、移位并保存了。

至少这个问题是得到解决了,不过再次看下后台的源文件,用的 jQuery 库仍然是一样的:

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js'></script>

而 WordPress 3.2.1 自带的是 jQuery 1.6.1 的。

有点不幸的却是进到 Add New Post 界面,彻底杯具了,可视编辑器已进入了崩溃的边缘,基本可视作不可用。又不得不在 Widget 处理完之后把 Use Google Libraries 重新启用后恢复正常。

把快要找到答案的问题又弄复杂了,肯定是有别的插件在从中作祟了。先不管了,WordPress 目前不是主业,至少目前能解决问题,虽然曲线了些。

还是,洗洗睡了吧!

参考:Can't edit and save saidebar widgets with WordPress 3.2.1

类别: WordPress. 标签: , , . 阅读(192). 订阅评论. TrackBack.

Leave a Reply

Be the First to Comment!

avatar
wpDiscuz